I was introduced to MikroTik routers many years by Kerry Hoath when he used to teach at the Cisco Academy for the Blind.
I have not looked back since. These routers have a command line interface and can be accessed by the mac addresses too. All very handy capabilities during troubleshooting and configuring.
I had a spare MikroTik router which I wanted to repurpose as a wireless access point. By this I mean that I wanted the router to grab the IP addresses from the gateway router. I did not want a double nat setup nor did I want to mess with establishing meshes etc.
The way to get the router as an access point goes something like this.
- Disable the dhcp server.
- Add the ports you want to the bridge interface of the router. In an existing configuration, this is usually done. Ensure that the interfaces belonging to the wireless lan are added to the bridge.
- Setup the wireless security profile and ssid with a few other settings.
I executed the above steps several times but no go. The wireless interface did not come up and when it did come up, the devices connected to it could not get to the internet.
The final answer was that I had not associated a dhcp client with the bridge interface. I had manually assigned the ip address of the router through the quick setup page. The right approach is as follows.
- /system reset-configuration no-defaults=yes
This is an important step because I found that if I was connected by the router’s IP address, I would be timed out and had to reset the router. - Create the bridge
/interface bridge add name=bridge-lan
- Add all the interfaces to the bridge
/interface bridge port add bridge=bridge-lan interface=all
- Add the dhcp client to the bridge interface
/ip dhcp-client add interface=bridge-lan disabled=no
- Disable ip forwarding because it is an unnecessary function
/ip settings set ip-forward=no
- Configure the wifi interface
/interface wireless set [find] ssid=YourWifiName frequency=auto disabled=no mode=ap-bridge
- Setup wireless authentication
/interface wireless security-profiles set [ find default=yes ] authentication-types=wpa2-psk mode=dynamic-keys wpa2-pre-shared-key=YourWifiPassword
- Add a specific to the router because you deleted the configuration
/user add disabled=no group=full name=YourUserName password=YourUserPassword
you can put the user name and password in quotes. - I am not too sure what this bit of code does,
/user remove [find (name="YourUserName" = false)]
Do ensure that you replace the values like “your password” with the actual values.
My thanks to all the posters at the following thread.
simple switch and WiFi AP (no dhcp, no nat)
who gave me the commands to reach here.